Extensions compatibles 3.3.x

phpBB-forum.ovh
Dernières mise à jour des styles : https://phpbb3styles.net/db33/
Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Extensions compatibles 3.3.x

Message par Origin ssl »

Lorsqu'une extension n'est pas compatible avec la version 3.3.0 de phpBB ce message s'affiche


erreur.png
erreur.png (156.44 Kio) Consulté 2127 fois




fa-commentingLa raison est que dans phpBB 3.3 il y a un changement dans Symfony qui nécessite que les fichiers .yml aient une syntaxe particulière.
Il existe des extensions qui ne sont pas encore en conformité avec la version 3.3.x de phpBB.



Afin d'éviter ceci voici la liste des extensions compatibles pour phpBB 3.3.x
* Mise à jour disponible - à tester


3.3.x.png
3.3.x.png (3.27 Kio) Consulté 2127 fois

  • phpBB 3.3.0

  • phpBB 3.3.1

  • phpBB 3.3.2




24 hour activity stats v1.0.9
Activation Justification v1.0.3
Add casimages service v1.0.2
Add User v1.0.4
Advanced BBCode Box v3.2.2
Animated PM Notification v1.0.5
Archive Forum v0.2.1
Auto Lock Topics v1.2.0
Ban Hammer v1.0.8
Blinking counter, for new pm and new notify v1.0.5
Board Announcements v1.1.1
Board3 Portal v2.1.0 > Patch français ici
Board Version on Footer v1.0.2
Breizh Ajax Checks v1.6.0
Breizh Country Flag v1.5.0
Breizh Shoutbox v1.0.0 > Lire ici
Calendar in Posting v1.0.3
Can Read Replies v2.0.3-RC
Copyright et réseaux sociaux v1.0.4
Custom Header Logo v1.0.3 > Lire ici
Custom Registration Agreement v1.0.0
Customize first post edit permissions v1.2.2 > Lire ici
Digests v3.3.0
Disable all extensions v3.1.0-RC1
Display Last Post v1.2.2
Downloadlog v1.0.3
External Links Open in New Window v1.0.6*
Favicon v1.0.1
First Post On every Page v2.0.2 > Lire ici
Google AdSense v1.0.0
Google Translator v1.0.3
Header Link v3.2.1-RC3
Hide 24 hour activity stats v1.0.0 > Lire ici
Hotschi's Downloads v8.0.7
Image Upload v1.1.0
Last Post Avatar v1.0.4 > Lire ici
Lightbox v2.0.1 > Lire ici
Live Search (as in google) v3.0.3
Login Redirect v3.1.0-RC1
Masquer les messages d’un forum v1.1.1
Memberlist avatar v2.0.1
Move Message v1.1.0
Modbreak v1.1.0
Move Add files button v1.0.0
Multi Links v2.2.6 > Lire ici
My Topics v1.0.12
NavBar for phpBB v1.0.3
NavBar Search v3.2.4-RC1
No Quote in Last Post v0.6.0
Notify Admin on Registration v1.0.1 > Lire ici
Obscure Contact Us v3.2.2
Pages v2.0.4
Purge Subscriptions Extension v1.2.0
PM Notify & Guest Register bar v1.0.5
Post Models v2.0.0
Pretty Topic v1.0.1
Private Message Box Status Bars v2.0.2
Privacy Policy v2.1.0-rc7*
Quick Login v1.1.1
Quick Title Edition v2.0.0-RC1
Recent topics v2.2.9
Scroll To Up and Bottom v1.0.2
Selective mass emails v1.0.9
Share On v2.0.1
Simple mentions v1.0.5
Simple Portal v1.0.3 > Lire ici
Smart Feed v3.0.13
Smart Subjects v1.0.0
Sortables Captcha v2.0.2
Sticky Bar v3.2.0-RC1
STK
STK Links v1.0.1
Surveiller les réponses par défaut v1.0.0
Thanks for posts v3.2.18
Topic Index v1.0.4 > Lire ici
Topic Cement Style v1.0.0-RC
Topic Preview v2.3.2
Topic Solved v2.3.0 > Lire ici
Topic Title Color v1.0.0-rc1 > Lire ici
Topics hierarchy v2.1.0 > Lire ici
Upload Extensions v3.2.0-RC
User Détails v3.1.0-RC1
User Recent Activity v2.2.1
Version Check Notifier 3.0.1
Welcome Back v1.0.15

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Lightbox v2.0.1

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnel l'effet Lightbox

Ce rendre ici : ext/vse/lightbox/styles/all/template/js/resizer.js

Éditer ce fichier : resizer.js

Vers la ligne 99 recherche ceci :

Code: Tout sélectionner

$(this).load();
Supprimes et remplace par ceci :

Code: Tout sélectionner

$(this).trigger('load');

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Last Post Avatar v1.0.3

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext\bb3mobi\lastpostavatar\config\services.yml

Il faut remplacer l'intégralité du fichier services.yml par celui-ci :

Code: Tout sélectionner

services:
    bb3mobi.lastpostavatar.listener:
        class: bb3mobi\lastpostavatar\event\listener
        arguments:
            - '@user'
            - '@path_helper'
            - '@dbal.conn'
        tags:
            - { name: event.listener }

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Hide 24h Activity Stats v1.0.0

Pour rendre compatible cette extension avec phpBB 3.3.0 il faut faire une modification de fichiers

Pour cela il faut éditer le fichier ext.php
ext/threedi/hideactivity24hrs/ext.php

On recherche cette ligne :

Code: Tout sélectionner

if (!( (phpbb_version_compare(PHPBB_VERSION, '3.2.1', '>=') && phpbb_version_compare(PHPBB_VERSION, '3.3.0@dev', '<')) || (phpbb_version_compare(PHPBB_VERSION, '3.1.10', '>=') && phpbb_version_compare(PHPBB_VERSION, '3.2.0@dev', '<')) ) )
On la supprime pour la remplacer par celle-ci :

Code: Tout sélectionner

if (!((phpbb_version_compare(PHPBB_VERSION, '3.2.1', '>=') && phpbb_version_compare(PHPBB_VERSION, '4.0.0@dev', '<')) || (phpbb_version_compare(PHPBB_VERSION, '3.1.10', '>=') && phpbb_version_compare(PHPBB_VERSION, '3.2.0@dev', '<'))))

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Breizh Shoutbox v1.0.0

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Pour cela il faut éditer le fichier tables.yml
ext\sylver35\breizhshoutbox\config\tables.yml

On remplace le contenu par ceci :

Code: Tout sélectionner

parameters:
    sylver35.breizhshoutbox.tables.shoutbox: '%core.table_prefix%shoutbox'
    sylver35.breizhshoutbox.tables.shoutbox_priv: '%core.table_prefix%shoutbox_priv'
    sylver35.breizhshoutbox.tables.shoutbox_rules: '%core.table_prefix%shoutbox_rules'

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Notify Admin on Registration v1.0.1

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Pour cela il faut éditer le fichier services.yml
/ext/dmzx/notifyadmin/config/services.yml

On remplace le contenu par ceci :

Code: Tout sélectionner

services:
    dmzx.notifyadmin.listener:
        class: dmzx\notifyadmin\event\listener
        arguments:
            - '@auth'
            - '@config'
            - '@dbal.conn'
            - '@user'
            - '@template'
            - '@request'
            - '%core.php_ext%'
            - '%core.root_path%'
        tags:
            - { name: event.listener }

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Topic Solved v2.3.0

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext\tierra\topicsolved\config\services.yml

Il faut remplacer l'intégralité du fichier services.yml par celui-ci :

Code: Tout sélectionner

services:
    tierra.topicsolved.controller:
        class: tierra\topicsolved\controller\main_controller
        arguments:
            - '@tierra.topicsolved.topicsolved'
    tierra.topicsolved.event:
        class: tierra\topicsolved\event\main_listener
        arguments:
            - '@tierra.topicsolved.topicsolved'
            - '@controller.helper'
            - '@template'
        tags:
            - { name: event.listener }
    tierra.topicsolved.event.acp_forums:
        class: tierra\topicsolved\event\acp_forums
        arguments:
            - '@tierra.topicsolved.topicsolved'
            - '@template'
            - '@request'
        tags:
            - { name: event.listener }
    tierra.topicsolved.topicsolved:
        class: tierra\topicsolved\topicsolved
        arguments:
            - '@dbal.conn'
            - '@user'
            - '@auth'
            - '@dispatcher'
            - '%core.root_path%'
            - '%core.php_ext%'

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Topic Title Color v1.0.0-rc1

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext/davidiq/topictitlecolor/config/services.yml

Il faut remplacer l'intégralité du fichier services.yml par celui-ci :

Code: Tout sélectionner

services:
    davidiq.topictitlecolor.listener:
        class: davidiq\topictitlecolor\event\main_listener
        arguments:
            - '@user'
            - '@dbal.conn'
            - '@template'
            - '@request'
            - '%core.table_prefix%'
        tags:
            - { name: event.listener }

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Topic Index v1.0.4

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Pour cela il faut éditer le fichier tables.yml
ext/dmzx/topicindex/config/tables.yml

On remplace le contenu par ceci :

Code: Tout sélectionner

parameters:
    dmzx.topicindex.table.topicindex: '%core.table_prefix%forum_lists' 

Avatar de l’utilisateur
Origin ssl
Membre
Membre
Messages: 301
Inscription: 12 janv. 2020, 15:12
Site internet:https://caforum.fr
OS:MacOS
Navigateur:Opéra
Contact:

Re: Extensions compatibles 3.3.x

Message par Origin ssl »

Customize first Post Edit Permissions v1.2.2

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Pour cela il faut éditer le fichier services.yml
/ext/gn36/firstpostedit/config/services.yml

On remplace le contenu par ceci :

Code: Tout sélectionner

services:
    gn36.firstpostedit.listener:
        class: gn36\firstpostedit\event\listener
        arguments:
            - '@auth'
            - '@user'
        tags:
            - { name: event.listener }

Répondre