Extensions compatibles 3.3.x

phpBB-forum.ovh
Dernières mise à jour des styles : https://phpbb3styles.net/db33/
Avatar du membre
Origin
Administrateur du site
Membre
Membre
Messages : 319
Enregistré le : 12 janv. 2020, 15:12
OS : MacOS
Navigateur : Opéra
Contact :

Re: Extensions compatibles 3.3.x

Message par Origin »

Custom Header Logo v1.0.3

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext/dmzx/chl/config/services.yml

Il faut remplacer l'intégralité du fichier services.yml par celui-ci :

Code : Tout sélectionner

imports:
    - { resource: tables.yml }
services:
    dmzx.chl.listener:
        class: dmzx\chl\event\listener
        arguments:
            - '@config'
            - '@template'
            - '@user'
            - '@dbal.conn'
            - '@request'
            - '%core.root_path%'
            - '%core.php_ext%'
            - '%dmzx.chl.table.header_images%'
        tags:
            - { name: event.listener }
    dmzx.chl.admin.controller:
        class: dmzx\chl\controller\admin_controller
        arguments:
            - '@config'
            - '@template'
            - '@user'
            - '@dbal.conn'
            - '@request'
            - '@log'
            - '%core.root_path%'
            - '%core.php_ext%'
            - '%dmzx.chl.table.header_images%'
Avatar du membre
MariePop's
Modération
Modération
Membre
Membre
Messages : 26
Enregistré le : 26 janv. 2020, 12:46
OS : Windows

Re: Extensions compatibles 3.3.x

Message par MariePop's »

Multi Links v2.2.6

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Pour cela il faut éditer le fichier tables.yml
ext/lmdi/multilinks/config/tables.yml

On remplace le contenu par ceci :

Code : Tout sélectionner

parameters:
    lmdi.multilinks.tables.multilinks: '%core.table_prefix%lmdi_multilinks'
Avatar du membre
Origin
Administrateur du site
Membre
Membre
Messages : 319
Enregistré le : 12 janv. 2020, 15:12
OS : MacOS
Navigateur : Opéra
Contact :

Re: Extensions compatibles 3.3.x

Message par Origin »

First Post On Every Post v2.0.2

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext/rxu/FirstPostOnEveryPage/config/services.yml

Il faut remplacer l'intégralité du fichier services.yml par celui-ci :

Code : Tout sélectionner

services:
    rxu.FirstPostOnEveryPage.listener:
        class: rxu\FirstPostOnEveryPage\event\listener
        arguments:
            - '@dbal.conn'
            - '@auth'
            - '@request'
            - '@template'
            - '@user'
        tags:
            - { name: event.listener }
Avatar du membre
Origin
Administrateur du site
Membre
Membre
Messages : 319
Enregistré le : 12 janv. 2020, 15:12
OS : MacOS
Navigateur : Opéra
Contact :

Re: Extensions compatibles 3.3.x

Message par Origin »

Simple Portal v1.0.3

Pour la version phpBB 3.3.0 il faut faire une modification sur deux fichiers pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext/stoker/portal/config/services.yml

Il faut remplacer l'intégralité du fichier services.yml par celui-ci :

Code : Tout sélectionner

services:
    stoker.portal.controller:
        class: stoker\portal\controller\main
        arguments:
            - '@config'
            - '@config_text'
            - '@controller.helper'
            - '@template'
            - '@user'
            - '%core.php_ext%'
    stoker.portal.listener:
        class: stoker\portal\event\main_listener
        arguments:
            - '@config'
            - '@controller.helper'
            - '@template'
            - '@user'
            - '%core.php_ext%'
        tags:
            - { name: event.listener }

Ensuite se rendre ici :
ext/stoker/portal/config/routing.yml

Il faut remplacer l'intégralité du fichier routing.yml par celui-ci :

Code : Tout sélectionner

stoker_portal:
    path: /portal.php
    defaults: { _controller: stoker.portal.controller:base }
Avatar du membre
Origin
Administrateur du site
Membre
Membre
Messages : 319
Enregistré le : 12 janv. 2020, 15:12
OS : MacOS
Navigateur : Opéra
Contact :

Re: Extensions compatibles 3.3.x

Message par Origin »

Topics Hierarchy v2.1.0

Pour la version phpBB 3.3.0 il faut faire une modification de fichier pour rendre fonctionnelle cette extension

Il faut se rendre ici :
ext/threedi/topicshierarchy/ext.php

Il faut remplacer l'intégralité du fichier ext.php par celui-ci :

Code : Tout sélectionner

<?php
/**
 *
 * Topics Hierarchy. An extension for the phpBB Forum Software package.
 *
 * @copyright (c) 2016 - 2017, 3Di, http://3di.space/32/
 * @license GNU General Public License, version 2 (GPL-2.0)
 *
 */

namespace threedi\topicshierarchy;

/**
 * Topics Hierarchy Extension base
 */
class ext extends \phpbb\extension\base
{
	/**
	 * Check whether the extension can be enabled.
	 * Provides meaningful(s) error message(s) and the back-link on failure.
	 * CLI and 3.1/3.2/3.3 compatible (we do not use the $lang object here on purpose)
	 *
	 * @return bool
	 */
	public function is_enableable()
	{
		$is_enableable = true;

		$user = $this->container->get('user');
		$user->add_lang_ext('threedi/topicshierarchy', 'ext_require');
		$lang = $user->lang;

		if ( !(phpbb_version_compare(PHPBB_VERSION, '3.2.0', '>=') && phpbb_version_compare(PHPBB_VERSION, '4.0.0@dev', '<')) )
		{
			$lang['EXTENSION_NOT_ENABLEABLE'] .= '<br>' . $user->lang('TH_ERROR_320_VERSION');
			$is_enableable = false;
		}

		if (!phpbb_version_compare(PHP_VERSION, '5.4.7', '>='))
		{
			$lang['EXTENSION_NOT_ENABLEABLE'] .= '<br>' . $user->lang('TH_ERROR_PHP_VERSION');
			$is_enableable = false;
		}

		$user->lang = $lang;

		return $is_enableable;
	}
}
Verrouillé