Prérequis phpBB 3

Informations, extensions
Dernières mise à jour des styles : https://phpbb3styles.net/db33/
Avatar du membre
Origin
Administrateur du site
Administrateur du site
Membre
Membre
Messages : 799
Enregistré le : 12 janv. 2020, 15:12
OS : MacOS
Navigateur : FireFox

Prérequis phpBB 3

Message par Origin »

phpBB 3.3.x a quelques exigences qui doivent être remplies avant de pouvoir l'installer et l'utiliser.
  • Un serveur Web ou un compte d'hébergement Web fonctionnant sur n'importe quel système d'exploitation majeur avec prise en charge de PHP
  • Un système de base de données SQL, l'un des suivants :
    • MySQL 4.1.3 ou supérieur (MySQLi requis)
    • MariaDB 5.1 ou supérieur
    • PostgreSQL 8.3
    • SQLite 3.6.15
    • MS SQL Server 2000 ou supérieur (via ODBC ou l'adaptateur natif)
    • Oracle
  • PHP 7.2.0 jusqu'à PHP 8.1 inclus avec prise en charge de la base de données que vous souhaitez utiliser.
  • Les modules PHP suivants sont requis :
    • json
    • mbstring
    • XML support
  • La fonction getimagesize() doit être activée.
  • La présence des modules suivants au sein de PHP donnera accès à des fonctionnalités supplémentaires, mais elles ne sont pas obligatoires :
    • Prise en charge de la compression zlib
    • Prise en charge FTP à distance
    • Assistance GD
Si votre serveur ou compte d'hébergement ne répond pas aux exigences ci-dessus, vous ne pourrez pas installer phpBB 3.3.x.

Source : https://www.phpbb.com/community/docs/IN ... ml#require